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Installation instructions

1 Minimum system requirements

Operating system 64-bit version of:

￭ Windows 10 Pro/Enterprise
￭ Windows Server 2019
￭ Windows Server 2016
￭ Windows Server 2012 R2

RAM 8 GB

Storage capacity Program: 1 GB

Data: 10 GB

Serial ports for devices with RS-232 interface

USB ports for devices with USB interface

Screen Resolution: 1024 x 768

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

The Windows user must have administrator rights in order to be able to install
the tiamo software.

2 Customizing energy options

During the determination, data loss may occur with certain energy options of
the operating system. Proceed as follows to customize the energy-saving plan
settings:

1 Under Control Panel ▶ System and Security ▶ Energy Options,
open the system settings that specify the behavior when the power
switch is pressed or the computer is folded shut.

 

2 Change the following settings:

￭ When pressing the power switch: Do nothing
￭ When pressing the energy saving button: Do nothing
￭ When closing the lid: Do nothing
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￭ Enable fast start-up: Deactivated

NOTICE

To change the Turn on fast start-up option, you may need to enable
it first as an administrator. To do this, click on Some settings are cur-
rently unavailable in the window.

 

3 Open the energy-saving plan settings under Control Panel ▶ System
and Security ▶ Energy Options. Now click on Change advanced
energy settings.

 

4 Change the following settings:

￭ Under Saving energy:
– Deactivation after: Never
– Allow hybrid standby mode: Off
– Hibernate after: Never

￭ Under USB settings:
– Selective USB energy-saving settings: Disabled

3 Single workplace installation

With the single workplace version tiamo light or tiamo full, you can install
both the tiamo client and the server on the computer.

1 Before the installation is started, disconnect all USB devices from the PC
on which tiamo is to be installed.

If the OMNIS Software is already installed on the PC, stop the Metrohm
OMNIS DeviceServer service via the Windows Task Manager.

 

2 Connect the USB stick with the tiamo installation file to the PC and start
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

 

3 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.

 

4 Read the license agreement for tiamo and accept it with [Yes].

 

5 After having accepted the license agreement, a window will appear
where you can enter the license code.
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Enter the license code for tiamo light or tiamo full and then click on
[Next >].

NOTICE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.
For more information about updating the program from a tiamo 2.x
version, see chapter 6, page 10 or chapter 7, page 13.

 

6 Confirm the target folder for the tiamo installation with [Next >] or
select a different target folder with [Browse…].
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7 You can define the paths for the database files and default backup files in
the Additional installation information window:

NOTICE

The database path must not be on a network drive. The default backup
path may also be on a network drive.

You can change the ports tiamo uses to communicate with the database
server and the administration server with the [Advanced…] button. If
the ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].

 

8 If you would like to create a shortcut on your desktop to start the tiamo
software, activate [Yes] and then click on [Next >].
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9 Confirm the selection of the program folder with [Next >] or select a dif-
ferent program folder.

 

10 The installation settings can now be checked. Start the copying procedure
with [Next >].
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11 Follow the instructions of the program until the following message
appears:

This message points out again which ports tiamo uses. Write down these
ports and inform your system administrator in case tiamo is not able to
connect to the database. Confirm the message with [OK].

tiamo will now be installed.

NOTICE

During the installation, all device drivers that are required for control-
ling the supported USB devices are installed or updated. If the driver
software by Thesycon needs to be updated, a message may appear.
Confirm the installation by clicking on the [Install] button.

 

12 Once the copying procedure has been completed you can make further
workplace settings:
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The option This client ID must exist in the current tiamo system.
can only be activated if a database from a previous installation already
exists or if you want to connect to a database server on another com-
puter (the latter only applies to tiamo multi).

If you enable this option, then tiamo checks whether the identifier you
have entered exists in the database. If this is the case, the identifier and all
associated settings will be adopted. With this option, reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

 

13 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current tiamo installa-
tion. Save this file on your hard drive for future reference and print it (add
to installation qualification).

NOTICE

An InstallLog file can be found in the installation directory of tiamo
under …bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

 

14 Complete the installation with [Finish].

If the OMNIS Software is already installed on the PC, restart the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.
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NOTICE

On the Windows 10 operating system, not all fonts are installed by default
anymore. This can lead to East Asian fonts missing and reports created in
MagIC not being displayed correctly. To solve this problem, you must install
the required fonts by adding the corresponding language in the Windows
settings.

4 Client/server installation

With the tiamo multi version (multi-client version with three licenses), you can
select during the installation whether you want to install only a client or a cli-
ent and a server (database server) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 Follow steps 1 to 6 of the single workplace installation (see chapter 3,
page 2).

 

2 The Additional installation information dialog appears. Here you can
select whether you want to install only a client or a client and a server
(database server) on your computer.

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.
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NOTICE

The database path must not be on a network drive. The default backup
path may be on a network drive.

With Client, only the client will be installed, and, with the button

,you have to select the database server (has to be installed in advance!)
you would like to use. The network server name or the IP address is
accepted as the name.

You can change the ports which tiamo uses to communicate with the
database and administration server under [Advanced…]. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].

 

3 All further installation steps correspond to those of the single workplace
installation from point 8 onwards (see chapter 3, page 2).

5 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current tiamo installation, start the
setup.exe file from the USB stick or click on Metrohm tiamo under Control
Panel ▶ Programs ▶ Programs and Features. Then select Change/
Remove:

Modify

With this option you can adjust the paths to the database and backup files,
and change the ports which tiamo uses for communication. With the tiamo
multi version, you can additionally change the path to the database server.
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If the database path is changed, the existing databases are automatically cop-
ied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.

￭ Repairing the installation
In case of a defective tiamo installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, tiamo can be
repaired with this option.

￭ Updating the installation
In case an older version of tiamo is installed, it will be updated to the new
version of tiamo, see chapter 6, page 10 or chapter 7, page 13.

CAUTION

When a tiamo 2.x version is updated, the databases will be converted to the
new version; depending on the size of the database, this may take some
time. For each database a progress bar which informs about the status of
the conversion is displayed.

The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!

License upgrade

A direct upgrade of your current installation to a tiamo version with additional
features is possible with this option:

￭ tiamo light to tiamo full or tiamo multi
￭ tiamo full to tiamo multi

In order to do this, enter your new license code in the next dialog window.

Remove

This option removes your tiamo installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

6 Program update with tiamo light/full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use with the new version.
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NOTICE

The program update to tiamo 3.0 is possible only from a 2.x-tiamo-version.

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

CAUTION

When a 2.x-tiamo version is updated, the databases will be converted to the
new version; depending on the size of the database, this may take some
time. A progress bar showing the status of the conversion is displayed for
each database.

The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!

1 Save the configuration database to an external directory using the backup
function of tiamo. In the Configuration program part, select the
File ▶ Backup ▶ Manually menu item. Select Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out. If necessary, copy the backup file to an external storage medium.

 

2 If desired, export the methods to an external directory in addition to the
backup with the configuration database (see above). In the Method pro-
gram part, select the File ▶ Method manager... menu item. Select the
desired Method group, mark all methods to be exported and click on
[Edit] ▶ Export…. Select the desired export directory and click on [OK].
The methods are exported to the desired directory. If necessary, copy the
method files to an external storage medium.

 

3 Save all determination databases created by you to an external directory
using the backup function of tiamo. In the Database program part,
select the File ▶ Database manager… menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is carried out. If
necessary, copy the backup file to an external storage medium.

 

4 Also save further files created by you in the installation directory (e.g.
export files) to an external storage medium.

 

5 Close tiamo. Connect the USB stick with the tiamo installation file to the
PC and start the setup.exe file.
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Then select Repair/Update program and click on [Next >].

 

6 When updating a 2.x-tiamo version, you must enter your update product
code and then click on [Next >].

 

7 Complete the installation with [Finish].

NOTICE

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
cessful installation is saved in the tiamo installation folder under
…bin\InstallLog.
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7 Program update with tiamo multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of tiamo multi.

NOTICE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

CAUTION

When a 2.x-tiamo version is updated, the databases will be converted to the
new version; depending on the size of the database, this may take some
time. A progress bar showing the status of the conversion is displayed for
each database.

The computer must not be restarted and Windows must not be shut down
as long as the conversion is running!

1 Make sure tiamo multi is closed on all clients.

NOTICE

In the bin subdirectory of the tiamo installation, you can find the Cli-
ents.exe application, with which all clients and their status can be dis-
played.

 

2 Open tiamo multi on the server and save the configuration database to
an external directory using the backup function of tiamo. In the Config-
uration program part, select the File ▶ Save ▶ Manually menu item.
Select the Backup directory, enter a name for the backup file and click
on [Start]. The backup is carried out. If necessary, copy the backup file to
an external storage medium.

 

3 If desired, export the methods in addition to the backup with the configu-
ration database (see above) to an external directory. To accomplish this,
select the File ▶ Method manager… menu item in the Method pro-
gram part. Select the desired Method group, mark all of the methods to
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be exported and click on [Edit] ▶ Export…. Select the desired export
directory and click on [OK]. The methods are exported into the desired
directory. If necessary, copy the method files to an external storage
medium.

 

4 Save all of the determination databases on the server to an external direc-
tory using the backup function of tiamo. In the Database program part,
select the File ▶ Database manager… menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is carried out. If
necessary, copy the backup file to an external storage medium.

 

5 Save other files which were created in the installation directory (e.g.
export files) to an external storage medium.

 

6 Updating the server

Close tiamo multi on the server and on all clients. Connect the USB stick
with the tiamo installation file to the PC and start the setup.exe file.

Then select Repair/Update program and click on [Next >].

 

7 When updating a 2.x-tiamo version, you must enter your update product
code and then click on [Next >].
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8 NOTICE

The update of tiamo multi consists of the server license and three cli-
ent licenses. If an existing installation contains additional client licenses,
these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

 

9 Complete the installation with [Finish].

NOTICE

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a suc-
cessful installation is saved on the server in the installation folder of
tiamo under bin\InstallLog.

 

10 Updating clients

Connect the USB stick with the tiamo installation file to each client in
turn and start the setup.exe file.

Then select Repair/Update program and click on [Next >]. Complete
the installation with [Finish].
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NOTICE

To facilitate the updating of many clients at once, the installation can
be copied from the USB stick to a writable medium and the file
tiamo_init.ini can be modified. There, user-defined parameters for the
installation (product code, installation path, server name, etc.) can be
set in advance, so that one needs only click through the installation.

NOTICE

An UpdateLog file with a list of all files that have been copied to the
client computer during the program update and with a confirmation of
a successful installation is saved in the client's tiamo installation folder
under bin\InstallLog.

If additional licenses were removed at the time of the server update or if fur-
ther additional licenses are to be added, proceed as follows:

Adding additional licenses

 

1 Open the directory C:\Users\'Username\AppData\Local\VirtualStore
\Program Files (x86)\Metrohm\tiamo\bin. If there is a file there
named license.mlic, delete it. Repeat this for each user.

 

2 Right-click on the file setup.exe and select Run as administrator.

 

3 Add the desired licenses in the Configuration program part under
Extras ▶ Program administration ▶ Licenses ▶ Add licenses.

The file license.mlic, which contains the standard product code and the
additional product codes, is stored in the bin directory of the program
installation (e.g. C:\Program Files (x86)\Metrohm\tiamo\bin).

NOTICE

For more information on adding additional licenses, refer to Chapter 9,
page 18

8 Installation of drivers

In normal cases, the installation routine of tiamo automatically installs all the
driver software necessary for actuating the supported devices.

It may be necessary to install individual driver software manually in combina-
tion with a few devices. This is the case if the operating system displays a mes-
sage when connecting a device to the computer, as e.g. Device driver soft-



8.101.8081EN / 2020-10-14 17

ware was not installed. No driver software found. The message should
also show the name of the corresponding device. Write down this name and
proceed as follows to install the driver software manually:

1 Open the Windows Device Manager. The corresponding device can be
found under Other devices.

 

2 Right-click on the device. The context menu opens.

 

3 In the context menu, select Update driver software. A dialog window
opens.

 

4 Select Browse my computer for driver software. The file selection
dialog opens.

 

5 Navigate to the installation folder of tiamo (default: C\Program Files
(x86)\Metrohm\tiamo).

 

6 Open the drivers subfolder. This contains a subfolder with the required
(*.inf) driver software file for each of the corresponding devices. For
example, the Avantes subfolder contains the driver software for the
Avantes spectrometer.

 

7 Apply the selection with [OK]. A Windows safety prompt is displayed. In
order to install the driver, click on [Install].

 

8 After successful installation, close the Device Manager.

9 Adding additional licenses

General

Windows 10 has a UAC (User Account Control), which permits running tasks
either as non-administrator or as administrator (without changes of user,
switching off or similar). For more information about this function, see https://
docs.microsoft.com/en-us/windows/security/identity-protection/user-account-
control/how-user-account-control-works.

This function can cause difficulties with client/server installations of tiamo.

Problem description

Additional licenses for the program should be added. For this purpose, the
product code for an additional 5 licenses, for example, has been added (on the
server) in the Configuration program part in the Program administration
dialog window (accessible via the Tools ▶ Program administration... menu
item, Licenses) tab).

Normally the license.mlic file, which contains the standard product code and
the additional product codes, is stored in the bin directory of the program
installation (e.g. C:\Program Files (x86)\Metrohm\tiamo\bin).

https://docs.microsoft.com/en-us/windows/security/identity-protection/user-account-control/how-user-account-control-works
https://docs.microsoft.com/en-us/windows/security/identity-protection/user-account-control/how-user-account-control-works
https://docs.microsoft.com/en-us/windows/security/identity-protection/user-account-control/how-user-account-control-works
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However, it may happen that the 5 licenses have been added and the
license.mlic file contains only the standard product code (for 3 licenses). If
this is the case, check whether there is a file named license.mlic in the C:
\Users\'Username\AppData\Local\VirtualStore\Program Files
(x86)\Metrohm\tiamo\bin directory. This file contains the product codes for
the standard licenses and the 5 newly added licenses, i.e. the additional licen-
ses were stored in the VirtualStore only for the Windows user who was log-
ged in on the PC at the time the additional licenses were added.

On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'Username'\AppData\Local
\VirtualStore\Program Files (x86)\tiamo\bin directory to the detail list of
the C:\Program Files (x86)\Metrohm\tiamo\bin directory.

The license.mlic file in the C:\Program Files (86)\Metrohm\tiamo\bin
directory determines the client/server functionality of the database server, how-
ever, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings). To fix this, the license.mlic file must be deleted from the
VirtualStore.

Remedy

￭ For new installations
– Start the program as an administrator.
– Add the product code for additional licenses as usual. The

license.mlic file in the C:\Program files (x86)\Metrohm\tiamo
\bin directory contains both product codes.

￭ For existing installations
– In the C:\Users\'Username'\AppData\Local\VirtualStore\Pro-

gram Files(x86)\Metrohm\tiamo\bin directory, check whether
there is a file present named license.mlic and delete it if necessary.

– Start the program as an administrator.
Add the product code for additional licenses as usual. The
license.mlic file in the C:\Program files (x86)\Metrohm\tiamo
\bin directory contains both product codes.

10 User rights for tiamo

In order for the logged-in user to be able to access all functions with tiamo,
the Windows system administrator must ensure that the permissions are set for
the directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data).

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup).

Modify User*

%PROGRAMDATA%\Metrohm** Modify User*
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Directory Permission Group name or
user name

Export directories

Directories where the exported files are to be saved.

Modify User*

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

Installation directory, e.g. %PROGRAMFILES(x86)%
\Metrohm\tiamo

Read & execute User*

* User = name of the user who is logged in

** During installation of tiamo the permission Full Control is set for the following groups: SYS-
TEM, Administrators, Users, Guests, Main users.

NOTICE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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